Installing SDM and CHDK the really simple way

2456

Comments

  • Hamish

    could you try again with Stick - first adding the line "debug=yes" to the stick.properties file (in the same folder as stick.jar). Then email me the resulting sticklog.txt file produced when stick terminates? I'd like to know what's going wrong.

    daveATzenoshrdlu.com
  • Dave: Just a report--I have successfully used ASSIST to update SDM for my three KAP cameras, Canon 570is (my go-to KAP camera), Canon G9 (my just a bit heavy KAP camera), and Canon S95 (bought for KAP on eBay but use it more as a convenient point and shoot camera in hand) . I had only minor challenges which were caused locally. Thanks for this truly "really simple" way to install SDM. I have benefitted in important ways from your contribution to the control side of KAP ventures.

    Robert R. Llewellyn
  • edited March 2013
    I am delighted by the potential of SDM! Accordingly, I have attempted to install it on a refurbished Canon a2200 (using a photo taken by a Canon S90 with ASSIST to download a build and install it, then replacing the DISKBOOT file with an unofficial one for the a2200).

    Unfortunately, I'm vexed by problems. (At first, I couldn't get ASSIST to locate a memory card, but, thanks to Dave Mitchell's January 31st post--thanks for everything here, Dave!--I'm now using the assistx.cmd.) If the card is formatted for the a2200, then ASSIST won't get past Step 4, where it reports: "Installation failed - see log for details" (but the log says the exact same thing, "...see log for details"); if the card is formatted for my computer (PC, Windows 7), then ASSIST works just fine and installs the S90 build. I switch the DISKBOOT files, and I'm ready to put the card back into my camera.

    That's when things fall apart. The camera won't start if the SDM card in it is locked. It doesn't react at all when I press the on/off button. I've got to pull out the card and the battery, and re-insert the battery with or without a card (unlocked) to get the camera to power up. If I do put in an SDM-installed card, with the card unlocked, well...then I'm unable to access SDM.

    Does anyone have a suggestion for how I might surmount this difficulty? I have managed to get the camera to start with a locked card, but not a card that had SDM (or CHDK) on it. What to do, what to do...
  • I apologize to all those who've had problems with ASSIST. The problems seem localised to Windows 7/8 users with cards > 4Gb and pre-2011 cameras (which requires partitioning the card into a small FAT16 and a large FAT32 partition). I only have Windows XP and cannot reproduce the problem myself. Until the problem is fixed, I advise Windows users with pre-2011 camera to stick to cards 4Gb or less.

    For UK people with the problem I'm happy to offer a card preparation service - send my your card with a photo on it taken with the camera in question and I'll post it back to you with SDM installed. I'll do this for users outside the UK too, but the two postal trips might take some time.
  • There goes Dave again...apologizing ( after all his efforts... for sdm etc... ) , and then offer service above and beyond..
    Thanks Dave,

    Paul
  • Ah, well. I went out and bought a 4GB card, and the problem is the same: the camera won't start if the SDM card in it is locked. It's frustrating. I know this camera works with SDM 'cos I've seen Michael L use the same model for KAP. What am I doing wrong?

    But no apologies are necessary, Dave--really, like Paul says, you've done "above and beyond."
  • Snaphappy,

    Try this: When powering the S100 with SDM....you need to hold down the power on button for about 3 seconds to power up the camera. The normal 1-2 second button push will not work. I normally use 16Gb cards but the 4Gb should work just fine.

    Good luck.

    Fly safe.

    WW
  • edited March 2013
    You should be using ASSIST to download the correct A2200 build rather than your unofficial one, which may be the wrong firmware version.

    Use a photo taken with the A2200 to do this..

  • edited March 2013
    In Stereo menu, if you choose Extend Lens then you only need to press the power button very briefly for the camera to boot and switch to Record mode.
    With the latest ASSIST builds there is a safety feature when booting.
    If Extend Lens is not checked, a brief press of the power button boots the camera into playback mode.
    Half-pressing the shutter button will NOT then extend the lens and switch to Record mode.
    There are instances where that has happened when the camera has been in a bag and the lens extended accidentally, causing expensive damage.

    To unlock the keys, you now have to press your designated ALT mode button.
    You can then extend the lens.
  • edited March 2013
    Um...when I try ASSIST, using a photo taken with my A2200, it says "No official SDM builds are available for this camera." Should I download a newer version of ASSIST? Is there such a thing?
  • Oops! I forgot to update the tables that ASSIST uses when I uploaded the A2200 builds. Just run ASSIST again and it should find the A2200 build.
  • edited March 2013
    Dave, thanks for the updated tables , but...

    It didn't work the first time I tried it. So I downloaded ASSIST again, and re-ran it (this is version 1.05). It recognizes the image I'm using as a photo taken with a Canon PowerShot A2200, firmware 100d, but it denies that there are any official SDM builds for the camera.

    Here, I'll try to install it using the S90 photo, and then switch the DISKBOOT file with one for the A2200.

    Yikes! The camera wouldn't power up with the card locked; when I try it without a card (or with the card unlocked), it turns on, extends the lens, then retracts the lens and flashes the message: Change the battery pack. Then it shuts down.

    Guess I'll look around for a Canon help forum, or maybe the users' manual. What does "Change the battery pack" mean, aside from the obvious?
  • Huh. According to the Canon PowerShot Forum, the message "Change the battery pack" means the camera has to be repaired or replaced. I'm not having a lot of luck at this whole KAP thing. Oh, well. The warranty wasn't good on my NEX 5R after I crashed it into the Bay, but maybe Canon will let me have another refurbished A2200.
  • Oops again - missed out a2200-100d from the table. It's there now.
  • Cool - I'll try it when I get the camera back from the Canon Factory Service Center.
  • Surely that does mean the obvious ... change the batteries.

    Have you tried that ?
  • Well, I pulled out the battery and put it back in quite a few times. I did not, it is true, try it with a different battery pack 'cos I don't have one. But over at the Canon PowerShot Forum (http://forums.usa.canon.com/t5/PowerShot/Powershot-SD900-battery-issues/m-p/11971/highlight/true#M458) someone experienced the same message "Change the battery pack," and was told by the Canon Product Experts that the camera needed to be repaired or replaced. I bought it ten days ago so I'm still covered by the warranty, and I've mailed it off to the Service Center.
  • edited March 2013
    My Canon SD870 will sometimes display "Change the battery pack" if I leave it sit for extended periods of time with the battery uninstalled. I found that the message occurs on my camera due to oxidation or residue on the electrical contacts (in the camera and on the battery). As alluded to in the Canon forum, cleaning both the camera and battery electrical contacts with a thin semi-abrasive pencil eraser until they are nice and shiny solves the problem for me. I've also had this happen occasionally on older cell phones.

    Mike
  • Um...hello. I'm back, with another problem (I feel like the slow kid in class, the one who never answers the teacher's questions and who always finishes the tests last).

    My A2200 was replaced by the Canon Factory Service Center. I have one just like in my hands right now, ready to be adapted for use as a KAP camera. I've slipped the memory card into my computer, and run ASSIST. I browse for image, select a photo taken by the camera; and, yes, "An SDM build for this camera is available for download." I click on the download button, and, wait for it..."common_files.zip failed to download." Hmmm. Click on the Help. The 'Download Failed' Page: This page should not be seen - such errors should not occur!

    ...any idea what I should do? Pack it up, and call it a day?
  • This problem surfaced with the previous version of ASSIST when I uploaded David Sykes latest builds. I fixed it, so if you download ASSIST again (should say version 1.06 on the title bar) things should work OK. My bad, not yours!
  • Everything is beautiful. The sky is a particularly vibrant shade of blue today, isn't it? And the clouds...aren't they especially white and fluffy? The birds are singing in the treetops, the flowers are smiling up at passersby - and I got SDM to work in my A2200! Nothing fancy (yet), just as a simple intervalmeter; but look out, world.

    Thanks, everyone! Firstly, to Michael L who directed me towards the refurbished A2200 (cheap! cheap!), but primarily to Dave Mitchell who made SDM possible (with a prod from David Sykes).
  • Glad to help, Snaphappy, but you have it the wrong way round. David Sykes is the author of SDM (i.e. the one who did all the hard work), I just wrote some software to make installing it easier!
  • Was the SD card write protect issue resolved?
  • edited April 2013
    Yes, it all works now. The ASSIST tables have been updated to include the A2200-100d. I downloaded ASSIST again and re-ran it. True, it didn't work when I tried it with the previous picture I'd taken (using the prior version of the camera, actually) - and, yes, I thought dark thoughts - but when I shot another with the new refurbished A2200 that the Canon Factory had sent me, everything worked out.

    I lock the card before loading into the camera, and it does boot up kinda funny. It flashes the standard Canon opening screen, then switches to one of white digits on a dark background, asking me to set the date and time. This only lasts a few seconds. Then it shows in gray digits "1.86", and goes to live view. I press the playback button which awakens SDM as an alternative program. I press the menu button, scroll down to SCRIPTING, and select that; then I scroll to Time-lapse and select that. I change "first delay seconds" to 1, I leave "shoot interval second" at 5, I leave "number of repeats" at 3, and I change "endless mode N/Y 0/1" from 0 to 1. I ignore everything else - which probably means I'm missing out on a great deal, but there you go.

    I took it out today, along with three kites, two of these SDM cards, and another camera...and I had the greatest KAP session of my career (but I'll talk about it in a different discussion thread, maybe in my "assessment of the Power Sled 24").
  • edited June 2013
    Dave,

    I just used ASSIST on a Windows 7 machine to install SDM on a 16GB SDHC card to use in an old A570 . The partitioning and installation went smoothly. Afterward, I found that I was unable to access the larger partition where the image files and SDM folders reside. At David Sykes' advice, I ran sdminste.exe to swap the partitions. Once that was done, I was able to access the larger partition in Windows 7.

    I'm wondering if there's a way to do this swap in ASSIST, and, if not, if it would be possible for you to add a swap feature to future versions of ASSIST? Or is there a simpler way to access the larger partition?

    Many thanks for creating ASSIST, Dave!

    - Michael
  • Or is there a simpler way to access the larger partition?

    Yes, use a Mac or Linux! Joke aside, CHDK has an option to "swap partitions" under "Miscellaneous stuff". So theoretically, this can be added to SDM as well.
  • edited June 2013
    I installed CHKD recently on a 8GB card, for my old S90 (which does not support booting from a large file system), using STICK on Windows 7.
    I was able to access the images on the large partition by using the swap partitions functions, BUT....

    After that I was not able to use CHDK in de camera: no CHDK firmaware on the big partition and no way to swap the partitions back...
    Had to copy the CHDK file to the big partition to make it work (followed by manual CHDK start + swap partitions to allow the auto-boot process)

    I know, it sounds lack black magic without the garlic... :-)
    Linux is easier, indeed, but is has no Photoshop...

    Cheers, Hans.
  • edited June 2013
    @Michael,

    Usually I use SDMinste to swap the partitions on SD Card.
    you can find it here
  • Just a brief note to say I'm in Italy for the next 18 days (padua until tuesday) and have no mac with me (just a very useful nexus 7 tablet).

    So I'm afraid I'm not able to offer much help!

    Dave
  • I'm unable to get my memory card to work with CHDK, S95, 4GB, 32FAT. I cannot even get the card reformatted to 16FAT. I'm not inexperienced with modest programming, but am really stumped. Are there any pages that give foolproof instructions for users like me? Many thanks. JIP
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion